`
从此醉
  • 浏览: 1044731 次
  • 性别: Icon_minigender_1
  • 来自: US
社区版块
存档分类
最新评论

位运算-BFS-Flip Game-POJ 1753

 
阅读更多

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
  1. Choose any one of the 16 pieces.
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

给十六个格子标上序号

0 1 2 3

4 5 6 7

8 9 10 11

12 13 14 15

便可以采用二进制记录不同的状态

01 0 0 0 1 1 0 0 0 1 1 0 1 1 1

1514 13 12 1110 9 8 7 65 4 32 1 0

此时便记录下了

14 10 9 5 4 2 1 0

最后采用十进制保存此时的状态 1表示‘b’,0表示‘w’,再做相应的翻转,既0 -> 1, 1 -> 0



#include<iostream>
#include<cstring>
using namespace std;
char ma[5][5];//用于输入
int states[65535]={0};//(核心部分)记录状态因为最大为2^16-1=65535所以数组大小为65535
int step[65535]={0};//记录步数
int rear=0,front=0;//记录头与尾
bool vis[65535];//用于记录是否搜过

//输入,并记录初始状态,放入队列首位置
void shuru()
{
    int i,state=0;
    for(i=0;i<4;i++){
        cin>>ma[i];
        int j;
        for(j=0;j<4;j++)
            if(ma[i][j]=='b')
                state|=1<<(i*4+j);
    }
    states[rear++]=state;//记录初始状态放入队列首
    vis[state]=true;//记录已走过
}

//反转一个,并产生影响
int fanzhuan(int stat,int i)
{
    int state=0;
    state|=1<<i;
    if(i%4!=0)state|=1<<(i-1);
    if((i+1)%4!=0)state|=1<<(i+1);
    if(i-4>=0)state|=1<<(i-4);
    if(i+4<16)state|=1<<(i+4);
    return (state^stat);
}

//BFS宽度遍历,搜索每种状态,不断放入队列中,找到后立即返回真(true)
bool bfs()
{
    while(front<rear)
    {
        int state=states[front++];//取出队列头,记录此时状态
        if(0==state||65535==state)//一旦找到,立即返回
        {
            cout<<step[state]<<"\n";
            return true;
        }
        int i;
        for(i=0;i<16;i++)//遍历每种状态
        {
            int st;
            st=fanzhuan(state,i);
            if(!vis[st])//防止重复遍历
            {
                states[rear++]=st;//不可以的加到队列尾部
                vis[st]=true;
                step[st]=step[states[front-1]]+1;//步数加1
            }
        }
    }
    return false;
}
int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    shuru();
    if(!bfs())cout<<"Impossible\n";
    return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics