`
从此醉
  • 浏览: 1044809 次
  • 性别: Icon_minigender_1
  • 来自: US
社区版块
存档分类
最新评论

线段树练习[单点更新] HDU 2795 Billboard

 
阅读更多

题目大意:有一个h*w的公告榜,可以依次在上面添加信息。每个信息的长度为x,高为1.

优先在最上面加入,如果空间足够的话,然后优先放在最左面。统计每条公告最终的位置,即它所在的行数。

这里是线段树来存储当前区间(i,j)的所有位置,剩余的最大空间。 初始化即为w,公告榜的宽。


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.

Sample Input
3 5 5 2 4 3 3 3

Sample Output
1 2 1 3 -1


#include <iostream>
#include <stdio.h>
using namespace std;

int tree[1000000]; // 记录当前区间所有位置,剩余的最大空间
int h,w,n,t;

int max(int a,int b){
    return a > b ? a : b;
}
void build(int l,int r,int k) {
    tree[k] = w;
    if (l == r) return ;
    int m = (l + r) >> 1;
    build(l,m,k*2);
    build(m+1,r,k*2+1);
}
void update(int t,int l, int r, int k){
    if(t > tree[k]){ // 如果当前无法加入,就直接返回
        printf("-1\n");
        return;
    }
    if(l == r){ //说明找到了合适位置可加入。
        printf("%d\n", l);
        tree[k] -= t;
        return;
    }
    int m = (l+r)/2;
    if(t <= tree[k*2])
        update(t, l, m, k*2);  //优先加入左子树,即上面
    else if(t <= tree[k*2+1])
        update(t, m+1, r, k*2+1);
    tree[k] = max(tree[k*2], tree[2*k+1]);
}

int main() {
	//freopen("in.txt", "r" ,stdin);
    while(scanf("%d %d %d", &h, &w, &n) != EOF){
        if(h > n)
            h = n;
        build(1,h,1);
        while(n--){ //更新
           scanf("%d", &t);
            update(t, 1, h ,1);
        }
    }
    return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics