`
从此醉
  • 浏览: 1044610 次
  • 性别: Icon_minigender_1
  • 来自: US
社区版块
存档分类
最新评论

母函数入门 HUD 1028 整数拆分

 
阅读更多

Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input
4 10 20

Sample Output
5 42 627

http://www.wutianqi.com/?p=596

这篇博文讲的很好!


#include <stdio.h>
int n;
int arr[130],tmp[130],i,j,k;
int main(){
	//freopen("in.txt","r",stdin);
	n = 120;
	for(i=0; i<=n; i++)
	{
		arr[i] = 1;
		tmp[i] = 0;
	}
	for(i=2; i<=n; i++)
	{
		for(j=0; j<=n; j++)
		{
			for(k=0; k+j <=n;  k += i)
			{
				tmp[k+j] += arr[j];
			}
		}
		for(j=0; j<=n; j++){
			arr[j] = tmp[j];
			tmp[j] = 0;
		}
		}
	while(scanf("%d",&n) != EOF){
	
		printf("%d\n",arr[n]);
	}

	return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics