`
从此醉
  • 浏览: 1034888 次
  • 性别: Icon_minigender_1
  • 来自: US
社区版块
存档分类
最新评论

HDU 1224 Free DIY Tour

 
阅读更多

Problem Description
Weiwei is a software engineer of ShiningSoft. He has just excellently fulfilled a software project with his fellow workers. His boss is so satisfied with their job that he decide to provide them a free tour around the world. It's a good chance to relax themselves. To most of them, it's the first time to go abroad so they decide to make a collective tour.

The tour company shows them a new kind of tour circuit - DIY circuit. Each circuit contains some cities which can be selected by tourists themselves. According to the company's statistic, each city has its own interesting point. For instance, Paris has its interesting point of 90, New York has its interesting point of 70, ect. Not any two cities in the world have straight flight so the tour company provide a map to tell its tourists whether they can got a straight flight between any two cities on the map. In order to fly back, the company has made it impossible to make a circle-flight on the half way, using the cities on the map. That is, they marked each city on the map with one number, a city with higher number has no straight flight to a city with lower number.

Note: Weiwei always starts from Hangzhou(in this problem, we assume Hangzhou is always the first city and also the last city, so we mark Hangzhou both1andN+1), and its interesting point is always 0.

Now as the leader of the team, Weiwei wants to make a tour as interesting as possible. If you were Weiwei, how did you DIY it?

Input
The input will contain several cases. The first line is an integer T which suggests the number of cases. Then T cases follows.
Each case will begin with an integer N(2 ≤ N ≤ 100) which is the number of cities on the map.
Then N integers follows, representing the interesting point list of the cities.
And then it is an integer M followed by M pairs of integers [Ai, Bi] (1 ≤ i ≤ M). Each pair of [Ai, Bi] indicates that a straight flight is available from City Ai to City Bi.

Output
For each case, your task is to output the maximal summation of interesting points Weiwei and his fellow workers can get through optimal DIYing and the optimal circuit. The format is as the sample. You may assume that there is only one optimal circuit.

Output a blank line between two cases.

Sample Input
2 3 0 70 90 4 1 2 1 3 2 4 3 4 3 0 90 70 4 1 2 1 3 2 4 3 4

Sample Output
CASE 1# points : 90 circuit : 1->3->1 CASE 2# points : 90 circuit : 1->2->1


利用Dijkstra算法的思想。依次加入每个点,更新dis[] ,表示interesting point


#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;
int t,n,points[110],m;
bool map[110][110];
int dis[110];
int path[110];

void printPath(int i){
	if(i == 0)
		return;
	printPath(path[i]);
	printf("%d->",i);
}

int main(){
	//freopen("in.txt", "r", stdin);
	cin >> t;
	int c=1;
	while(t--){
		cin >> n;
		for(int i=1; i<=n; i++){
			cin >> points[i];
		}
		points[n+1] = 0;
		cin >> m;
		int a,b;
		memset(map, 0,	sizeof(map));
		memset(dis, 0,	sizeof(dis));
		memset(path, 0,	sizeof(path));
		for(i=1; i<=m; i++){
			cin >> a >> b;
			map[a][b] = true;
		}
		for(int k=1; k<=n+1; k++){
			for(i=k+1; i<=n+1; i++){
				if(map[k][i] ){
					if(dis[i] < dis[k] + points[i]){
						dis[i] = dis[k] + points[i];
						path[i] = k;
					}
				}
			}
		}

		printf("CASE %d#\npoints : %d\ncircuit : ",c++,dis[n+1]);
		printPath(path[n+1]);
		if(t)
		printf("1\n\n");
		else
			printf("1\n");
	}
	return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics