`
从此醉
  • 浏览: 1048741 次
  • 性别: Icon_minigender_1
  • 来自: US
社区版块
存档分类
最新评论

HDU 1074 状态DP

 
阅读更多

Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.

Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.

Sample Input
2 3 Computer 3 3 English 20 1 Math 3 2 3 Computer 3 3 English 6 3 Math 6 3

Sample Output
2 Computer Math English 3 Computer English Math
Hint
In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.


这里使用搜索+剪枝


#include <iostream>
#include <string>
#include <string.h>
#include <algorithm>
using namespace std;

const int MAXN = 32868;
int pow[17] = {1,2,4,8,16,32,64,128,256,512,1024,2048,4096,8192,16384};
int hash[MAXN];
int temp[20]; //临时解决方案
bool used[20]; //
int path[20];
int ans,i,j,t,n;

typedef struct Node{
	int cost,dead;
	char name[300];
}Node;

Node arr[20];

//穷举法 + 剪枝
void dfs(int index, int cnt,int sum,int cur,int state){

	if(cnt == n){
		if(sum < ans){
			ans = sum;
			for(int i=0; i<n; i++){
				path[i] = temp[i];
			}
			return;
		}
	}

	//剪枝. 如当前的结果比以前算出的结果大,就直接返回
	if(hash[state] != -1 && sum > hash[state])
		return;
	if(hash[state] == -1 || hash[state] > sum){
		hash[state] = sum;
	}
	
	for(int k=0; k<n; k++){
		if(!used[k]){
			int tempCur,tempSum;
			if(cur + arr[k].cost > arr[k].dead){
				tempSum = sum + cur + arr[k].cost - arr[k].dead;
			}else{
				tempSum = sum;
			}
			tempCur = cur + arr[k].cost;
			used[k] = true;
			temp[cnt] = k; //记录
		
			dfs(k, cnt+1, tempSum, tempCur, state + pow[k] );
			
			used[k] = false;
		}
	}
}

int main(){
freopen("in.txt","r",stdin);
	cin >> t;
	while(t--){
		cin >> n;
		for(i=0; i<n; i++){
			scanf("%s %d %d", arr[i].name, &arr[i].dead, &arr[i].cost);
		}
		memset(hash,-1,sizeof(hash));
		memset(used,false,sizeof(used));
		ans = 0x3fffffff;
		dfs(-1,0,0,0,0);
		cout << ans << endl;
		for(i=0; i<n; i++){
			printf("%s\n",arr[ path[i] ].name);
		}

	}
	return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics