`
从此醉
  • 浏览: 1034615 次
  • 性别: Icon_minigender_1
  • 来自: US
社区版块
存档分类
最新评论

Human Gene Functions - LCS 动态规划 HDU-1080

 
阅读更多

Problem Description
It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them.

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function. One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.

A database search will return a list of gene sequences from the database that are similar to the query gene. Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.

Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of the genes to make them equally long and score the resulting genes according to a scoring matrix.

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal length. These two strings are aligned:

AGTGAT-G
-GT--TAG

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.

* denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

AGTGATG
-GTTA-G

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the similarity of the two genes is 14.

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.

Output
The output should print the similarity of each test case, one per line.

Sample Input
2 7 AGTGATG 5 GTTAG 7 AGCTATT 9 AGCTTTAAA

Sample Output
14 21



#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

int map[5][5] = {
		{5,-1,-2,-1,-3},
		{-1,5,-3,-2,-4},
		{-2,-3,5,-2,-2},
		{-1,-2,-2,5,-1},
		{-3,-4,-2,-1,-100000}
};
int opt[110][110]; //opt[i][j] 表示 字符串1的前i个和字符串2的前j个最大匹配度
int i,j,t,m,n;
char str1[110],str2[110];
int arr1[110],arr2[110];
int index[256];
int mymax(int a,int b,int c){
	int t = a > b ? a : b;
	return t > c ? t : c;
}
int main() {
	index['A'] = 0;
	index['C'] = 1;
	index['G'] = 2;
	index['T'] = 3;
	index['-'] = 4;
	//freopen("input.txt","r", stdin);
	cin >> t;
	while(t--){
		scanf("%d %s %d %s",&m,str1,&n,str2);
		opt[0][0] = 0;
		for( i=1; i<=m; i++){ //处理第一列
			arr1[i] =  index[str1[i-1]];
			opt[i][0] =opt[i-1][0] +  map[arr1[i]][4];
		}
		for( i=1; i<=n; i++){ //处理第一行
				arr2[i] =  index[str2[i-1]];
			opt[0][i] =opt[0][i-1] + map[arr2[i]][4];
		}
	
		for(i=1; i<=m; i++){
			for(j=1; j<=n; j++){
				opt[i][j] = mymax( opt[i-1][j-1] + map[ arr1[i] ][ arr2[j] ], 
					opt[i-1][j] + map[arr1[i]][4], opt[i][j-1] + map[arr2[j]][4]);
			}
		}
		cout << opt[m][n] << endl;
	}
	return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics