`
从此醉
  • 浏览: 1034509 次
  • 性别: Icon_minigender_1
  • 来自: US
社区版块
存档分类
最新评论

动态规划- Super Jumping! POJ-1087

 
阅读更多


Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16653Accepted Submission(s): 7093


Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output
For each case, print the maximum according to rules, and one line one case.

Sample Input
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0

Sample Output
4 10 3

最大递增子段和,状态方程:sum[j]=max{sum[i]}+a[j]; 其中,0<=i<=j,a[i]<a[j]


#include <iostream>


using namespace std;


int arr[1001];
int n;
int opt[1001];
int main() {
	int max=0;
	while (cin >> n, n) {
		for (int i = 0; i < n; i++) {
			cin >> arr[i];
			if(arr[i] > max)
				max = arr[i];
		}


		//状态方程:opt[j]=max{opt[j]}+a[i]; 其中,0<=j<i,a[j]<a[i]
		opt[0] = arr[0];
		int max = 0;
		for(int i=1; i<n; i++){
			max = 0;
			for(int j=0; j<i; j++){
				if(opt[j] > max && arr[j] < arr[i])
					max = opt[j];
			}
			opt[i] = max + arr[i];
		}
		max = 0;
		for(int i=0; i<n; i++)
			if(opt[i] > max)
				max = opt[i];
		cout << max <<endl;
	}
	return 0;
}




分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics