`
从此醉
  • 浏览: 1047067 次
  • 性别: Icon_minigender_1
  • 来自: US
社区版块
存档分类
最新评论

ZOJ 2412(Farm Irrigation)

 
阅读更多

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.


Figure 1

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

ADC
FJK
IHE
then the water pipes are distributed like
Figure 2

Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

Input

There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

Output

For each test case, output in one line the least number of wellsprings needed.

Sample Input

2 2
DK
HF

3 3
ADC
FJK
IHE

-1 -1

Sample Output
2
3



使用深度优先遍历,4个方向。如果遍历到则置为'0',只遍历一次。

#include <iostream>
#include <stdio.h>
using namespace std;
int M, N;
char map[60][60];
int dir2[4][2] = { {-1,0},{0,-1},{1,0},{0,1} };
int dir[11][4] = {
		{1,1,0,0},{0,1,1,0},{1,0,0,1},{0,0,1,1},{0,1,0,1},{1,0,1,0},{1,1,1,0},{1,1,0,1},{1,0,1,1},{0,1,1,1},{1,1,1,1}
};

void dfs(int m,int n){
	int index = map[m][n] - 'A';
	map[m][n] = '0';
	//cout << m << "<>" << n << endl;
	for(int i=0; i<4; i++){
		if(dir[index][i]){

			int tempx = n + dir2[i][0];
			int tempy = m + dir2[i][1];

			if( tempx >=0 && tempx < N && tempy >=0
					&& tempy < M && map[tempy][tempx] != '0'){
				int tempIndex = map[tempy][tempx] - 'A';
				int k = i+2;
				if(k > 3)
					k -= 4;
				if(dir[tempIndex][k])
					dfs(tempy, tempx);
			}
		}
	}
}

int main() {
//	cout << "!!!Hello World!!!" << endl; // prints !!!Hello World!!!

	while(cin >>M >> N){
		if(M <= 0 || N <= 0)
			break;

		for(int i=0; i<M; i++)
			scanf("%s", map[i]);

		int cnt = 0;
		for(int i=0; i<M; i++){
			for(int j=0; j<N; j++){
				if(map[i][j] != '0'){
					dfs(i,j); //i是行,j是列
					cnt ++;
				}
			}
		}
		 cout << cnt << endl;
	}
	return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics