`
从此醉
  • 浏览: 1047174 次
  • 性别: Icon_minigender_1
  • 来自: US
社区版块
存档分类
最新评论

题目1022:游船出租

 
阅读更多

http://ac.jobdu.com/problem.php?pid=1022

题目描述:
现有公园游船租赁处请你编写一个租船管理系统。当游客租船时,管理员输入船号并按下S键,系统开始计时;当游客还船时,管理员输入船号并按下E键,系统结束计时。船号为不超过100的正整数。当管理员将0作为船号输入时,表示一天租船工作结束,系统应输出当天的游客租船次数和平均租船时间。
注意:由于线路偶尔会有故障,可能出现不完整的纪录,即只有租船没有还船,或者只有还船没有租船的纪录,系统应能自动忽略这种无效纪录。
输入:

测试输入包含若干测试用例,每个测试用例为一整天的租船纪录,格式为:
船号(1~100) 键值(S或E) 发生时间(小时:分钟)
每一天的纪录保证按时间递增的顺序给出。当读到船号为-1时,全部输入结束,相应的结果不要输出。

输出:
对每个测试用例输出1行,即当天的游客租船次数和平均租船时间(以分钟为单位的精确到个位的整数时间)。
样例输入:
1 S 08:10
2 S 08:35
1 E 10:00
2 E 13:16
0 S 17:00
0 S 17:00
3 E 08:10
1 S 08:20
2 S 09:00
1 E 09:20
0 E 17:00
-1
样例输出:
2 196
0 0
1 60



#include <stdio.h>
int main()
{
	int index;
	char type;
	int end[101];
	int start[101] = {-1};
	scanf("%d",&index);
	int sum = 0;
	int cnt = 0;
	int h,m,i;
	while(index != -1){
		if(index == 0){
			for(i=0; i<101; i++)
				start[i] =-1;
			if(cnt != 0) //因为要四舍五入。不能直接用int类型输出
				printf("%d %.0lf\n",cnt,((double)(sum/(double)cnt)));
			else
				printf("0 0\n");
			sum = 0;
			cnt = 0;
		}
		getchar(); //这个地方是为了正常读取
		type = getchar();
		scanf("%d:%d",&h,&m);
		if(type == 'E'){
			end[index] = h*60 + m;
			if(start[index] != -1){  //说明有租船记录
				sum += (end[index] - start[index]);
				cnt ++;
			}
		}
		else
			start[index] = h*60 + m;

		scanf("%d",&index);
	}
	return 0;
}

/**************************************************************
    Problem: 1022
    User: 从此醉
    Language: C
    Result: Accepted
    Time:10 ms
    Memory:908 kb
****************************************************************/


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics