`
从此醉
  • 浏览: 1046987 次
  • 性别: Icon_minigender_1
  • 来自: US
社区版块
存档分类
最新评论

母函数练习2 HDU 1085

 
阅读更多

Problem Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!
“Oh, God! How terrible! ”



Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!

Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.

Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.

Sample Input
1 1 3 0 0 0

Sample Output
4




#include <stdio.h>
#include <string.h>
int num1,num2,num3,arr[10001],tmp[10001];

int main(){
	freopen("in.txt","r",stdin);
	while(true){
		scanf("%d %d %d", &num1, &num2, &num3);
		if(num1 == 0 && num2 == 0 && num3 == 0)
			break;
	//	int l = num1 + num2 * 2 + num3 * 5;
		int i,j;
		memset(arr,0,sizeof(arr));
		memset(tmp,0,sizeof(tmp));
		for(i=0; i<=num1; i++){
			arr[i] = 1;
			tmp[i] = 0;
		}
	//	int m = max(num1, num2 * 2 + num1);
		int m = num2 * 2 + num1;
	//	printf("%d\n",m);
		for(i=0; i<=m; i++){
			for(j=0; j+i <= m; j += 2){
				tmp[j+i] += arr[i];
			}
		}
		for(i=0; i<=m; i++){
			arr[i] = tmp[i];
			tmp[i] = 0;
		}

		m += 5*num3;

		for(i=0; i<=m; i++){
			for(j=0; j+i <= m; j += 5){
				tmp[j+i] += arr[i];
			}
		}
		
		for(i=1; i<=m; i++){
			if(tmp[i] == 0)
				break;
		}
		printf("%d\n",i);

	}
	return 0;
}



分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics