`
从此醉
  • 浏览: 1045384 次
  • 性别: Icon_minigender_1
  • 来自: US
社区版块
存档分类
最新评论

动态规划-Largest Rectangle in a Histogram- HOJ 1506

 
阅读更多

Largest Rectangle in a Histogram

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7296Accepted Submission(s): 2037


Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input
7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0

Sample Output
8 4000


还有一个类似的题。

动态规划-面积最大的全1子矩阵

关键点都是遍历两次,找到左界限和右界限。


#include <stdio.h>
typedef long long int64;
int64 n;
int64 arr[100002];
int64 left[100002], right[100002];
int main() {
	//freopen("input.txt", "r", stdin);
	while (scanf("%I64d",&n), n) {
		for (int i = 1; i <= n; i++) {
			scanf("%I64d",&arr[i]);
		}
		arr[0]=-1;arr[n+1]=-1;
		int64 tmp;
			for (int i = 1; i <= n; i++) { //求左界限
				tmp = i;
				while(arr[i] <= arr[tmp-1]) {
					tmp = left[tmp-1];
				}
				left[i] = tmp;

			}
			int64 ans = 0,max;
			for(int i=n; i>=1; i--) { //求右界限,同时求最大值
				tmp=i;//
				while(arr[i] <= arr[tmp+1]) {
					tmp = right[tmp+1];
				}
				right[i] = tmp;
				max = (tmp-left[i] + 1) * arr[i];
				if(max > ans)
					ans = max;
			}

			printf("%I64d\n",ans);

		}
		return 0;
	}




分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics