`
从此醉
  • 浏览: 1046178 次
  • 性别: Icon_minigender_1
  • 来自: US
社区版块
存档分类
最新评论

并查集练习之 POJ(709) Oil Deposits

 
阅读更多

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=709


The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.


Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.


Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0


Sample Output

0
1
2
2



统计油田个数。 由于8个方向。实际上可以在读入数据的时候只对左上四个方向进行 合并。 因为后面的也会合并上面的。

这个也可用DFS深度优先遍历做。个人觉得效率要低点。


#include <iostream>

using namespace std;
int father[10001]; //把二维转化为1维,使用并查集
char map[101][101]; //

void init(int len) {
	for (int i = 0; i <= len; i++)
		father[i] = i;
}

int find_set(int i) {
	if (i != father[i]) {
		father[i] = find_set(father[i]);
	}
	return father[i];
}

void join(int x, int y) {
	int i = find_set(x);
	int j = find_set(y);
	if (i != j)
		father[i] = father[j];
}
//只用查找左上四个方向就行了(后面的还为读取到)
int dir[4][2] = { { -1, 0 }, { -1, -1 }, { 0, -1 }, { 1, -1 } };

int main() {
	int m, n;
	//m为列  n为行
	while (cin >> m >> n) {
		if (m == 0)
			break;
		init(m * n); //初始化并查集
		//cout << find_set(2) << endl;
		for (int i = 0; i < m; i++) {
			for (int j = 0; j < n; j++) {
//				scanf("%c",&map[i][j]);
				cin >> map[i][j];
//				cout << map[i][j];
				int tempj, tempi;
				//如果当前读入为 @, 就和左上比较,可以加入一个集合
				if (map[i][j] == '@') {
					for (int k = 0; k < 4; k++) {
						tempj = j + dir[k][0];
						tempi = i + dir[k][1];
						if (tempi >= 0 && tempi < m && tempj >= 0
								&& tempj < n) {
							//可以加入一个集合
							if (map[tempi][tempj] == '@') {
								join(i*n + j, tempi * n + tempj);
							}
						}
					}
				} else {
					father[i*n + j] = -1; //后面要统计并查集的集合。 设为-1不统计没有油田的位置
				}

			}
		}

		//查找有几个集合
		int cnt = 0;
		for (int i = 0; i < m; i++) {
			for (int j = 0; j < n; j++) {
				int index = i*n + j;
				if (map[i][j] == '@' && father[index] != -1 && find_set(index) == (index)){
					cnt ++;
				}
			}
		}
		cout << cnt << endl;
	}
	return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics